Go Back   Pit Bike Club > Pit Bike Discussion & Reviews > Pit Bike Discussion

Pit Bike Discussion Honda, Kawasaki, Xsport, Thumpstar, MonsterMoto & others

Reply
 
Thread Tools Display Modes
Old 13-11-2006, 05:23 PM   #1
jook
 
jook's Avatar
 
Join Date: Nov 2006
Age: 26
Posts: 2
Bike: Rampage 110cc
Thumbs down Electric Start Problem

Hi
I have quite a strange question i wonder if anyone can help me.
I have a Orion Rampage 110cc manual pit bike and when i try to use the electric start it doesnt seem to work.
When i put the key in and turn and press the start button with the fuel on and the ignition switch pressed but nothing happens.
It doesnt even attempt to turn over.
But this is the strange bit.
When i kick start the bike and it is running in neutral if i pull the front brake and press the start button it makes a noise as if electric is running through something.
But then if i turn the bike off and hold the brake in and press the button not a sound!!
Please help
Thanks
Jack
jook is offline   Reply With Quote
Pit Bike Club Sponsor
Lucky MX
Old 13-11-2006, 06:38 PM   #2
Thumpstar Sam
 
Thumpstar Sam's Avatar
 
Join Date: Aug 2006
Location: hull
Posts: 97
Bike: Thumpstar
my mate had 1 and it wont work try pullin the clutch in then press the button c if that works
Thumpstar Sam is offline   Reply With Quote
Pit Bike Club Sponsor
Old 13-11-2006, 06:59 PM   #3
Matty21
 
Matty21's Avatar
 
Join Date: Jul 2006
Location: Hull,east yorkshire
Posts: 301
Bike: Ive got a thumpstar =]
i know...try the clutch idea cos thatsn the way proper bikes do it.
__________________
Matty21 is offline   Reply With Quote
Old 13-11-2006, 07:09 PM   #4
WPB Pitbikes
PBC Legend
 
WPB Pitbikes's Avatar
 
Join Date: Oct 2006
Location: Welsh Pit Bikes
Posts: 5,387
Bike: WPB 2WIN
Those are the classic symptoms of a failing battery, just enough juice to allow a kickstart then, as the alternator charges it up a bit you'll get some life from it on trying to restart it.

If its a 12v battery a opposed to a 6v, then give it a charge with a car Charger, if it still dont respond then the battery is knackerd.
Also check for a voltage at the starter terminals with a bulb or meter, press the starter and it should light up or give a reading on a meter.

Just cos the bike starts on kick doesent mean the battery is alright, if its something new thats happened its almost certainly the battery.

Some bike wont start on electric when in gear for obviuos reasons,thats why pulling in the clutch will get a start.

Last edited by WPB Pitbikes; 13-11-2006 at 07:15 PM.
WPB Pitbikes is offline   Reply With Quote
Old 13-11-2006, 07:30 PM   #5
jook
 
jook's Avatar
 
Join Date: Nov 2006
Age: 26
Posts: 2
Bike: Rampage 110cc
Thanks for everyones help.

No it dont work when i hold clutch and brake down. i will just have to charge it i think

Thanks

Jack
jook is offline   Reply With Quote
Old 14-11-2006, 09:15 PM   #6
Powermod1
Banned
 
Powermod1's Avatar
 
Join Date: May 2006
Posts: 22
Were finding alot of people prefer not to have electric start anymore?
How often do the elctrics fail on your bikes?
Powermod1 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump