Go Back   Pit Bike Club > Pit Bike Discussion & Reviews > The Workshop

Latest discussions at Pit Bike Club:

  • Pad instalment wpb
    Right this is wrecking my brain I have my new wpb 125 The front pads where so tight I had to loosen the bleed...
  • stomp yx140 over heating
    Hi sorry if you keep getting threads like this but couldnt find any that helped me. I have a stomp yx140 oil cooled and...
  • Exhaust can bolts melted
    Looking to take the can off and put it onto another but the bolts seem to be melted/seized onto it. Any tips/tricks to...

Reply
 
Thread Tools Display Modes
Old 12-06-2007, 09:09 PM   #1
Adam
Guest
 
Adam's Avatar
 
Posts: n/a
Flywheel/magneto related problem

Hi there, got this recent problem with my 125cc pit bike.

was just riding along when the chain came off, immediately cut the engine, the bike then refused to start and when i took the flywheel cover off, part of it (the bit that seperates the flywheel from the front sprocket) had snapped probably from the chain, and the mounts to the stator (bit thats next to the flywheel) have snapped. they seem fixable but I need the flywheel off so i can easily get to where they snapped.

now, i have a puller to get the flywheel off but the hooks (or w.e they are called) wont fit around the outside of the flywheel cause the gearbox case gets in the way and the gap is too small. i can post pics if they are needed.

i have considered other stuff like trying to lever the flywheel off but i dunno whether that will damage it. any advice on how to fix the stator mounts, or more importantly how to get the flywheel off?

Thanks in advance.
  Reply With Quote
Old 16-06-2007, 06:09 PM   #2
Adam
Guest
 
Adam's Avatar
 
Posts: n/a
Re: Flywheel/magneto related problem

Anyone?
  Reply With Quote
Old 23-06-2007, 08:19 PM   #3
Despise
superpit1337
 
Despise's Avatar
 
Join Date: Oct 2006
Location: England
Age: 27
Posts: 20,503
Bike: CRF70/CRF50base
Re: Flywheel/magneto related problem

can try lean it off or mallet tap it. Other than that im not really sure. post a pic on here
Despise is offline   Reply With Quote
Old 24-06-2007, 10:12 PM   #4
Stu78
 
Stu78's Avatar
 
Join Date: May 2007
Location: Preston
Age: 37
Posts: 27
Bike: 150cc BFD150A
Re: Flywheel/magneto related problem

Use a copper mallet and give it a good hard smack on the edge of the flywheel.
Stu78 is offline   Reply With Quote
Old 24-06-2007, 10:25 PM   #5
Despise
superpit1337
 
Despise's Avatar
 
Join Date: Oct 2006
Location: England
Age: 27
Posts: 20,503
Bike: CRF70/CRF50base
Re: Flywheel/magneto related problem

The bit thats snapped off will be the netrual or pickup.
Despise is offline   Reply With Quote
Old 27-06-2007, 10:26 PM   #6
Adam
Guest
 
Adam's Avatar
 
Posts: n/a
Re: Flywheel/magneto related problem

It was the pickup that was snapped off.

thanks for the help guys but by the time you replied i figured out the problem and found out how to get the flywheel off. Lever two screwdrivers behind the flywheel while getting someone else to tap the central shaft with a hammer. So easy when you know how to do it lol. Bought a new stator plate and got a spark so it's ok now. Those stator plate screws are fvk hard to get off.

Having trouble getting it started tho, if i cant find my answers in other topics i'll post a new topic.
  Reply With Quote
Old 27-06-2007, 10:27 PM   #7
Despise
superpit1337
 
Despise's Avatar
 
Join Date: Oct 2006
Location: England
Age: 27
Posts: 20,503
Bike: CRF70/CRF50base
Re: Flywheel/magneto related problem

best to get a puller.
Despise is offline   Reply With Quote
Old 06-07-2007, 10:59 AM   #8
Despise
superpit1337
 
Despise's Avatar
 
Join Date: Oct 2006
Location: England
Age: 27
Posts: 20,503
Bike: CRF70/CRF50base
Re: Flywheel/magneto related problem

I didnt catch up with you, are you all good now?

If not here m8 http://www.pitbikeclub.co.uk/showthread.php?t=4392
Despise is offline   Reply With Quote
Old 06-07-2007, 12:03 PM   #9
Adam
Guest
 
Adam's Avatar
 
Posts: n/a
Re: Flywheel/magneto related problem

Yeah the stator business is all fixed now, but for this problem with starting i've been having, i made another thread for it.
  Reply With Quote
Old 06-07-2007, 12:40 PM   #10
Despise
superpit1337
 
Despise's Avatar
 
Join Date: Oct 2006
Location: England
Age: 27
Posts: 20,503
Bike: CRF70/CRF50base
Re: Flywheel/magneto related problem

Originally Posted by Adam View Post
Yeah the stator business is all fixed now, but for this problem with starting i've been having, i made another thread for it.
LINK ME
Despise is offline   Reply With Quote
Advertisement
Reply
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
magneto wiring problem help please manwee The Workshop 3 28-04-2012 11:57 PM
125 magneto problem mattwill89 The Workshop 0 17-02-2012 12:23 PM
magneto/flywheel cover Z3p Wanted 1 27-07-2009 06:59 PM
magneto/stator/flywheel help spozer The Workshop 2 28-02-2009 06:26 PM
magneto problem bandogge The Workshop 8 09-03-2007 12:45 AM